Using Android Studio


#1

Hi,
I have built an app in bubble, used dropsource to deploy to a mobile and I’m trying to now publish to the playstore via Android Studio.
I have completely hit a wall with Android Studio, I really need some help here.
Currently i have imported my project into Android Studio (i think) and I’m trying to follow Dropsource instructions however the screenshots they supply are different from what I’m seeing.
Id really appreciate a kick along here. Heck I’d be even willing to pay someone if they could show me how to do this over a video chat?

Thanks in advance.

Here is what i see on Android studio


#2

What seems to be the issue? In android studio you shouldn’t have to worry about looking through the files just to export.

First, simply import the project by following the dropsource instructions

Next, set any version codes/ect by going to the top left and clicking File>Project Structure> Modules

Then, go to the top middle and click Build>Generate Signed Bundle or APK>Select Android App Bundle>Next>Create or Choose a Keystore>Next> Set your export location, Underbuild types select release, under signature version select both V1 and V2> Finish

Hopefully that helps.
Mackenly


#3

Hi,
Thanks.

I think I’ve imported as per dropsource instructions but, here is what i see what i click ‘Build’.

I would happily pay someone to show me how to do this via a video chat screenshare.
Capture2


#4

This sounds like an Android Studio issue, a few Stack Overflow posts popped up after a quick Google:


Might be worth restarting, maybe updating Android Studio if any updates are available…


#5

@dwrd72, for good measure, I saw a Build ID in your screenshot so I pulled the source code down locally and opened in Android Studio on my side. After it fully opens, I clicked on the Build menu and I see the available option. I did nothing more than that. I think agree this seems like an issue with your Android Studio software potentially here.


#6

This happens to me sometimes when using Andoid Studio, what I try is as follows…

#1 Make sure there are no processes running (bottom right of the screen).

#2 Check to make sure there are no build errors in any of the consoles/log. These are often very informative and help you know what the issue is.

#3 Verify everything is up to date including sdks, gradle stuff, ect.

#4 Try “Make Project” and “Rebuild Project” (Pretty much just refreshes everything)

#5 Restart Andoid studio and start the whole import process again.

Again these are just a few things I’ve tried that in the end made it right. I really don’t know what causes it :joy:

Best of luck,
Mackenly


#7

Thanks for this Mackenly, it chimes with some of what I saw in stack overflow and should be a good post for us to point people at in future if they encounter this or any other import problems. Android Studio can be pretty unpredictable lol, drives me mad at times… :dizzy_face:


#8

Thanks for the comments guys.
I have just tried loading Android studio on a different computer.
I left the computer for about 4 hours, came back and got this?
My last drops of motivation are fast evaporating here…


#9

Looks like it’s still downloading components.

To give perspective the best internet available in my location is about 5mb down and the first time I downloaded Android Studio it took all day and that was only with the minimum extras. Depending on your connection it may take a looooong time.


#10

It does seem like it’s taking a while but it also does seem like it it’s moving forward in the right direction.


#11

I left it overnight and was at that same point. I will try again sometime.
My download speed is 60+ mbs


#12

I should have mentioned, i actually got this during the set up. Could this have be the cause of it not fully downloading & installing?
1


#13

Hello @dwrd72 I’ve never seen that error before. You may want to consult any potential support they supply or perhaps Stack Overflow or any Android Studio FB groups/forums to get Android Studio specific eyes on the issue here for better guidance than I can provide for you. You’ll want to have Android Studio setup properly. That error certainly could be an area of concern for proper setup of the IDE.