[Solved] API Error


#1

This appears to be a dropsource bug that is not allowing this property to be selected. Everything appears just fine in the API as far as I can tell (and works on another request that is exactly the same).

Capture6346836


#2

Hi @mackenly.j, could you show a bit more detail here including the action you’re using and ideally the section of the swagger spec where it defines that field? First guess would be a data type mismatch between what’s in the swagger and the action parameter you’re trying to select the response field for.


#3

Okay, I’ll try to get it to you. It’s all exactly the same as another request it’s just that this one does not work.


#4

It appears to be not showing an error anymore but the builds are failing… I tired removing some actions that were triggered when the user opens the app but it didn’t seem to help.


#5

OK, our support team will look into your build fail. Had you updated the API before the build failed? If so the source of the error could be related to any changes that were in it.


#6

No, I didn’t end up updating the api cause dropsource stopped showing an error. But wouldn’t build. (I tried it over the weekend and got a build failure too)


#7

OK so it wouldn’t normally change what options were available in an action parameter unless something else had changed in the app. In any case we’ll look into the build fail and take it from there!


#8

Okay, I don’t think I changing anything but I may have.


#9

Hey Mackenly, just catching up with the info that was passed to you from the engineers yesterday, it sounds to me like it was related to a Set Value action in the 200 event (if I remember rightly it’s a Set Property action in the backend so that’s why that was in the message they’ve sent you, apologies for any confusion there). Would that have been the action you had in your screenshot above? Might be worth clearing the selection, saving the action, then editing it and selecting it again in case that resets something…


#10

Okay, I re done the set value actions in the 200 event for the finals request but it still failed. New ID: 1039836499907797020


#11

OK I’ve passed this back to the engineers, bit of a weird one but we’ll get there…!


#12

In the mean time I’m gonna make some modifications to the UI. That won’t effect the troubleshooting of the actions will it?


#13

Nope you should be absolutely fine, it seems specific to your API/spec.


#14

This issue was solved on 9/13/2018 thanks to Dropsource support.


#15

Oh good, phew… :sweat_smile: