[Resolved] Swift compiler error


#1

Keep getting this warning when trying to run the build (to test the app on local devices). Any idea what I can do?
Am running XCode 9.1 beta
Couple of screengrabs here:


#2

Hey Richard,

Unfortunately we do not support new beta releases of XCode and Swift until they are officially released. Once Swift 4.0.1 comes out, our source code and frameworks will be compatible with it.


#3

If you want to use the source code in the meantime, you will need to use Xcode 9 with Swift 4 (which is the default setup)


#4

Ah, my bad - thanks Nate.