[Resolved] One signal, cannot set up ios sdk


#1

After following the documentation in one signal, I was stuck in the stage where I had to go to xcode and choose, file > New > Target.
However when I opened xcode I was not able to click on Target as it seems not available to click.

I don’t understand. We are using dropsource to edit our app, then why do we have to go back to xcode to set up the one signal.
I created the app in apple developer account, and set up the .p12 certificates using the provisioning tool in one signal.

I cannot seem to go ahead with the ios SDK set up.
It also says that I need to contact dropsource to get some certificates, which I havent received yet, but already placed a request.
Is it because of this missing certificate from dropsource that I cannot go ahead and set up the ios sdk. Frankly I cannot see how my app and xcode is related unless I have to download the source code, or the one signal set up only comes into effect after paying for the sourcecode in dropsource.


#2

Hello @hg.hermes.l, you don’t need to follow the iOS sdk setup since we provide that setup for you in your project already. We can create a certificate for you. Would you please build your app for a device (not simulator) and supply us with the build id for that here?

@Nate, flagging you here on @hg.hermes.l request for a push cert for his project.


#3

Hi @wade
my Build ID: 1095803439463663824

This is the latest device build I have.

Thank You


#4

1097336107591740849 @hg.hermes.l is a build for the simulator. I need you to build it for a device instead and share that build id with me instead. Device Builds do more behind the scenes things related to these push notifications and it sets up the project so that I can create the certificate for you.


#5

Hi @wade I must have sent the wrong one.
This is the build that’s in my phone.

Build ID: 1098297935270599940


#6

Hi, @wade
any update on the push certificates?


#7

hi @wade
is the push certificate taken care of or do I have to wait for a certificate to receive from the team.
Please advise.

@sue


#8

@paul could you please look into this.

I created this post 12 days ago, i got a response after 3 days, and I am waiting for another response for the past 6 days. No one cares to update.


#9

Hi @hg.hermes.l I do apologize for the delay in communication. We’re still working on an issue regarding issuing Push Certificates. It appears an internal issue and I’m working with Engineering to solve it for you. We have dedicated time locked in today to put more resources into this direct issue. You’re not alone in this current issue and we’re working to get it solved so you can move forward.

I’m sorry for the delay in communication again. As soon as I have more information, I will pass it ASAP.


#10

@hg.hermes.l I have hope that we’ve got this solved over here. I just need to wait for Engineering to come into the office this morning and help me with a re-setup process and I should be able to produce this Certificate. I will send it to you in a message here as soon as I have it.

Here’s hoping we’ve finally got this squared away for you. Thanks so much for all your patience.
-Wade


#11

To update this… I’ve sent you your new Push Certificate in a private message for OneSignal.


#12

Thank You @wade for all your help. I appreciate everything and sorry for being impatient.
Thanks