[Resolved] Build Failed - No todos


#1

Build ID: 725372439388223750

Project Name: AB Significance Test

Building the iOS version of this application is failing. I’d like to preview it using https://appetize.io/, but the build will not finish. There are no todos left and no obvious errors being thrown.

Is there anymore information I can provide here?


#2

Nate reached out via email and let me know that they were doing late night maintenance. I tested and this is working now.


#3

Sorry for posting against a resolved ticket. But I also encountered a Build Failed with no todos or warnings. I was building a todo app as per the examples. I think I did a mistake of not testing each step. Consequently i did not capture an error made when picking elements on tasks page of the app. So its until after following up step by step with the tutorial document that I was able to find the error below:

So my question is, is there a way to disable a page to make it easier to move closer to the source of an error during troubleshooting?


#4

Hi Tim, I can see your build fails coming up in our logs, our developers are looking into it and will reach out to you via the chat once we have a solution. In case it helps just now it looks like an issue related to referencing something inside a dynamic tile from outside it - the most likely culprit is an action referring to an element that’s inside a tile.

Troubleshooting build fails is definitely something we’re focused on improving because we know it’s tough right now. The team is working on a number of improved error reporting and debugging features you’ll hopefully see in the platform soon. In the meantime don’t hesitate to ask via the chat in the editor and we’ll look into any issues you’re having!


#5

Hi Tim, just providing a bit more info on your build fail - in your page Tasks, you have a Run Request action on tap of a button named Add Button. In an event associated with that request (usually either a request status code event or an element load event) you’re referencing an element inside a list tile - if you remove that reference your build fail will hopefully be solved.


#6

Thanks for prompt response @sue. Actually I had already pinpointed the source of the error. But it took me a lot of time and this was my concern and I wanted to know how members deal with such.

But as you have indicated, the team is working on improving error reporting and debugging. Hope it will be easier to debug this kind of error as we go.


#7

Hi, Have tried building my app but its not building, On my previous day it was building.
Have tried doing a duplicate for the project for the project, i deleted all the pages and added a new page with a single Textview but am still getting the same error. what could be the possible solution?


#8

I would say if your app was building successfully and without any changes the build start failing you should give it some time(maybe a day).
There are times dropsource is doing some backend stuff that may be causing that issue.
I’ve had this experiences in the past where my app that was building successfully starts to fail and vice-versa. Though things seem to be stable these days. Haven’t experienced that much now.
So instead of deleting stuff and redoing them, just take a break on it and come back the next day and if it was something internal from Dropsource’s end it may be fixed by then.


#9

Hi @DenisMutegi, is this a different issue to the one you have a support request open for?


#10

Problem resolved thank you @sue, I had two different apps one was not building but now its building,after sometime it started building and the other other i asked for the support, the issue is now resolved.