Properties Not Changing on iOS


#1

For the life of me, I can’t figure out why a button text color won’t change based on an action that is set that works on other buttons on the page…

I’ve deleted and re-added the button and it still won’t change the text color from black to white based on the ‘label title color’ action.

I also have another page that won’t, for whatever reason, display an activity indicator.

Is there something under the hood that can be reviewed @wade or have you ever heard of this before?


#2

I know that on iOS, for buttons, properties occur on the .selected .deselected etc States of buttons. I haven’t tried this myself yet to adjust the color like you’re attempting. I can tinker a bit.

I’m not sure about the activity indicator, can you share a build Id and show me where you’re trying and also how to get to that location when I run it up in simulator? I can see what I can uncover.


#3

It’s quite bizarre.

Other buttons on the same page using the same actions change the text color fine.

I can’t get the ‘round trip’ button to change colors on Build ID: 1167613382789077440 to black background (white font) - font stays black when clicked with black/black as a color scheme.

For the activity indicator, same here, i have deleted and re-added the activity indicator, even unhid it completely and it just doesn’t want to show. Heirarchy of elements on the page match other pages where the indicator shows correct and constraints are set fine.

To view the button issue after auto-cred click here and click between one-way / round-trip to see the relationship and issue:

image

To view the activity indicator issue click here:

image


#4

Any chance you were able to help us on this one @wade ?


#5

What’s the diFFerence here? Let’s see iF you can spot it…



#6

Not sure what you mean with the indicator… you’re hiding it on view appeared? I need more context.


#7

Yeah that was me…

I thought maybe capital vs. Lower case would fix it but it didn’t unfortunately.

Just can’t get the text color to change to fffff (white) on click.

I actually cant get it to change to any color at all from testing with other color codes and i have removed the button and added new to no avail. Its like there is an error I am unable to see on my end or something.

I changed it to something close to white now f1f1f1 but still, text color remains black. Build ID: 1170437711865608377

And just for further testing, I added a brand new 3rd button to the page ‘TEST’ just to sort out what is going on here and try and get the font color to change on a simple set value On Click and it simply won’t change! I don’t get this one at all. Button 1 functions fine, button 2 and 3 will not function the same way and won’t change the font color. Been at this removing and replacing and adding and configuring to no avail unfortunately. Am I losing it? :sweat_smile:

Here’s the build ID with the text button: Build ID: 1170776315806133410

image

And my apologies to you @wade, I overlooked the ‘page appeared’ there and removed it and it seems to be working OK now.

One thing I’m struggling with on iOS, is the pages that we have set in the tab bar at the bottom, when you navigate to them and run an api call On Page Load, by default the activity indicator is visible, then on code 200 it is hidden by set value. BUT… when we click off that page then hit the same tab button to pull up the original page again, the activity indicator is visible again, but the api call isn’t run (because it’s already loaded from the 1st instance) so the activity indicator remains in place. I’m trying to prevent that from appearing and thought maybe the ‘page appeared’ event would solve that but in this case it doesn’t.

I see that the activity indicator has a setting ‘hide when stopped’ but i can’t locate the Set Value to ‘stop’ it anywhere which should hide it. Wondering what a suggestion is here for browsing back to the same page when an activity indicator is present without having to re-run the api call each time the page is loaded and or appeared simply to hide that activity indicator if I can’t use the ‘page appeared’ event.


#8

Hmm, I do see that hex code there has 5 instead of 6 f’s but also… Have you tried using a Segmented Control by chance? These are made for this-or-that situations.

Activity Indicators start and stop with actions. There the 1st actions you see when you open the screen…


#9

Thanks @wade I will try the segmented control.

When one Segment is clicked, what is the action to change colors of the segment(s) in the segment control?

I can’t seem to be able to select one or the other segment:

image

Maybe I’m looking in the wrong properties section?


#10

I mean, they natively change naturally. I dunno if you’re going to find a ideal solution. Maybe the “tint color” property. Not really sure. Segmented controls are already setup to have 1 segment selected and deselect the others and the colors are determined natively. Tinkering outside that may or may not be possible in Dropsource.