My App Keeps Crashing At Startup


#1

When I run my build in the online viewer it works fine.

But when i run it on mobile it keeps crashing on start up.

How do i dissect this?

Build ID: 1118949600951962283


#2

Hi @justincrabbe… A way to see what’s happening on Mobile is to download the source code and run it using Xcode (iOS) / Android Studio (Android). Plug your phone into your computer and run the app on it, When it crashes you’ll find information in the debugger. This is a good way to break it down. I did this on my side but didn’t find a crash here. Feel free to let me know what you uncover with your specific device.


#3

I downloaded android studio for the first time.

Where / how do i ‘activate’ the on-startup debugger?

I’ve plugged in the phone (new android Samsung S10+) - importantly, it ran fine on my older S8+ 1 week ago.


#4

Any assistance with this?


#5

Do you have a build Id I can check out on my side?


#6

Hi @wade please check out Build ID: 1118949600951962283


#7

I pulled this Build ID down and ran in Android Studio. It booted up to the login screen fine on a Pixel 2. Hmm, I’m not exactly sure since I don’t see any errors from device. You’ll have to help me out if you have a specific device that isn’t functioning properly with the app.


#8

How do I help is my question?

How do i setup android studio to scan my cell phone when i try and boot up the app on the brand new Samsung s10+?


#9

“Scan your cell phone”… I’m not sure what you mean. You might have to Google this 1. I’m not sure what you mean by this.


#10

This is what I’m trying to understand:

I can plug the phone into the computer but I do not know how to set up android studio to scan my phone in a way that will produce the reason for the error that is causing the app to crash on startup on my S10+ but not the S8 I had just a week ago.


#11

I understand now. Thanks for clarifying. In Android Studio, near the “Run App” button, you’ll see another option that looks like a little ladybug for running the app with debugger activated. This helps produce great error information in the console log.


#12

So I plugged it in to my computer and started android studio under a new project but for some reason these buttons are greyed out for me.

I don’t think I have my settings correct or I don’t think it’s able to ‘see’ that my phone is even connected to Android studio. Perhaps there is a setting that tells Studio to scan the phone vs. an apk file that I provide a file path for??


#13

Justin,

What happens if you run it in an emulator through android studio? You can test apps on “virtual devices” through Android Studio.


#14

I tried that, but I get the below error:

image

I’m quite inexperienced with Android Studio so I really don’t know if I’m doing this correctly.

All I know is that the apk downloaded from Dropsource on an Android running Samsung S8+ worked fine, then I upgraded my device to the Samsung S10+ and it crashes on startup consistently.

Is there anything else that I can provide Dropsource to review this without having the S10+ handset?

Thanks very much


#15

What’s version android is that s10 running? And would you provide a successful build Id. I can setup a simulator and try that out. It won’t represent all the settings your individual phone is set as but it’s still worth trying out.


#16

It’s running One UI version 1.1 Android Version 9.

Try the Build ID: 1126889846401611268


#17

I am pulling down this project for this build id and running on my Pixel 2 using Android 9 and it’s working without a problem. I wish I could help more. Without seeing a crash or error information or something more to go on, I’m not going to be much help. This could be even be related to something device specific, or even something specific to a setting in that certain devices settings too.

I wish I could help more here.


#18

I totally get it @wade so no worries at all I appreciate the help and believe it’s simply my lack of knowledge surrouding Android Studio and how to test on a mobile device.

Is there an app or a way that i can send a log or a report from the device itself?

I scratch my head how a device using the same OS 9.0 Android works fine as mine did on my Samsung S8 and then when I upgraded to the Samsung S10+ it no longer works… The apps and settings on the S8 vs. new S10+ are all just your standard basic settings… I haven’t ‘hacked’ the phone or anything. Basically took it out of the box and tried to load the app and it fails constantly.


#19

I wonder if this resource will help you. It’s from developer.android.com. It’s a breakdown on how to debug your app using Android Studio and your device. There is a link with instructions on how to put your phone in debugging mode and how to set up Android studio to selected the connect device when you click the debug app button inside Android Studio.

https://developer.android.com/studio/debug