Module compiled with Swift 4.2 cannot be imported by the Swift 5.1.2 compiler


#1

Hi,

Xcode is giving me an error when I am trying to archive my app during the preparation for launching the app on the app store. I get this error:

“Module compiled with Swift 4.2 cannot be imported by the Swift 5.1.2 compiler”

What could be causing this? I am running the most recent version of Xcode on MacOS Catalina.

Some people are talking about this being a compatibility issue with the new version of swift or xcode: https://www.reddit.com/r/swift/comments/ba08ea/module_compiled_with_swift_421_cannot_be_imported/

Has anyone installed a previous version of xcode and been able to publish successfully?

Solution Edit: I realized this is no longer an issue if one installs xcode 10.1, which runs on Swift 4.2 in the compiler.


#2

Yes that’s the answer in your edit. Great job troubleshooting. As we developer the next version of Dropsource, we’ve paused on continual Dropource builder updates for new Xcode compiler versions. Using Xcode 10.1 currently will give you success.