Keep Getting Errors When Opening The Date & Time Picker.....?


#1

I have a button that has an action to display a time picker.

I get this error every time:

image

My action:

What am I doing wrong?

Both my date picker action + time picker action result in errors and freeze the app.


#2

Can I ask what data type you’re using for your device variable? I just tried this with a string variable and it worked so you may be using an incompatible type.


#3

I changed it to String from Date.

It’s working now.

But why can’t I set the complete date as a value? All it allows me to do is select the day of the month, or the year, or the month. Not the complete date.

I’m planning to pass it over to Bubble.

image


#4

How you pass it will depend on the format you need it to be in at the Bubble side but you may need to combine a few actions to get the result you need. You’ll probably something like this sequence of actions:


Including the format you need it to arrive at your Bubble backend.


#5

Why does mine always require the time?

Yours doesn’t ask for the time:

EDIT: looks like maybe your screenshot is cut off and maybe it does indeed ask for the time but I’m not sure.


#6

Yep it’s just a bit of a screengrab to help point you in the right direction, this stuff typically requires a bit of trial and error to get it right for your own backend.