IOS Time Picker, result in DB is alway 1970,11:PM in the DB


#1

Hello ,

On IOS, I try to save a date coming from the time picker, in a bubble DB, the date appears in the DB, but always at 1970 , 11:00PM , only the day of the month is correct.

I tried to create a current date, to set the time picker, but same result, need help on this, on Android with the same API no issues

Thanks


[SOLVED]Getting time from date-time picker
#2

Hi @LOIC, I wonder if you need to turn the timestamp into a Date object or something - for the previous query (below) you had about sending dates to Bubble, did you get that to work or is this still the same issue?

p.s. just out of interest, the 1970 will likely be coming from UNIX time:


#3

In case this helps, I was messing about trying to write the date value from the picker into the page and this successfully outputs a date string (using a Foundation - Date variable):

This is what it output in the running app:

So am wondering if sending that to Bubble might be worth a try…?


#4

Hello Sue, I tried , but it crashes the application,

I had the issue already in my first post, but I though it will be be easy to fix. Very complicated in IOS the date with bubble


#5

So you tried sending a Date object, is that right?


#6

yes it seems the only option is to link directly the Time Picker to the Parameter of the API ,as a date timestamp, other options so far crash the app ,or the API do not respond.

In Android it works well , on IOS, there is the wrong timing issue


#7

Ah so binding directly to the time picker works for the api but the logic to do it that way doesn’t work for your app, am I understanding that correctly?


#8

Good news!, your method works! , the crash had another reason! Thanks you !


#9

Oh good! Thanks for the update. :tada:


#10

Hey @sue, I tried this method you described: Formatting the date to string and then setting it to a text field. Then I tried to send that to the Date variable in bubble, but it gives me this error: {“statusCode”:400,“body”:{“status”:“INVALID_DATA”,“message”:“Invalid data for field Completion Date: Expected a date, but got a string (original data: “03 July 2018 at 18:36”)”}}. Am I missing something from your explanation?

Thank you!
Travis


#11

Hi @Sindewald, I’m not an expert in working with Bubble but it sounds like your approach might need to vary depending on whether you’re sending the data from ios or android. You may need to experiment e.g. with sending the date object itself as opposed to the string. I’d also recommend using the network log to check what your app is actually sending when the request runs:


#12

Hi @Sindewald

I had the exact same issue and have finally got the Date to be accepted by Bubble and it was correct!

This was my setup


(Here is the format for you to paste in: MMM d, yyyy h:mm a)

I then bound the “pinStartDateString” page variable to my API Parameter (Which is a “Date” field type in Bubble).

Hope this helps

Ollie


#13

Are you send this from an Android app or an iOS app to Bubble?

Reason I ask is that I formatted mine exact same to you (copying your format) and I pass it to Bubble which receives a Date as a “Date” type, but it crashes my app inside of Dropsource.


#14

HI. Your method works for the date but somehow it doesnt work for the time part. The time is always wrong and also the am and pm is not right whenver I choose a date and send it to bubble.
However when I display the date and time in dropsource it displays them correctly.