Error message when using Xcode.. please help


#1

I am getting this error message saying the SDK here is outdated


#2

Hello @marcel… I saw the screenshot you sent privately but I will answer publicly in case it helps others. Based on the error recommendation in the screenshot, what version of Xcode are you trying to upload with. I think it looks like at least Xcode11 due to the Dark Mode look of it but correct me if I’m mistaken.

Try downloading Xcode 10.1 to perform source code opening and sending to the App Store.

Here’s where you can download other version of Xcode as well. 10.1 is what you want to use. https://developer.apple.com/download/more/


#3

#4

Went to 10.1 and had issue still… You guys HAVE to do some sort of update to this sdk asap. We are paying for nothing Wade age this point. With all due respect. This should have been implemented long before now…


#5

Basically… I cannot build any of my apps that I built in Drop source now…


#6

@marcel That error comes from a 3rd party plugin (Not Dropsource). I looked up that plug-in error you’re receiving from macOS Mojave Patcher and the program is for older Mac’s to be able to run newer software that Apple doesn’t support for older hardware. You’re going to want to look into why you’re receiving these errors as they don’t pertain to Dropsource but your hardware and software.

Dropsource apps, in their current state, will successfully build and run through the Xcode version 10.1.


#7

Thanks for responding wade. But this comes straight from drop source. That’s all I use. Can I send you the project file so you can see. I really need to get to the bottom of this . Maybe you can take a look at the code and it will show you something that may have been overlooked - I’m running Catalina and as soon as I updated to this I got the error message when I tried to submit the build. In face I submitted the build and published the app. The next day after I tried to send an update cause To fix meta data on the profile page after I downloaded Catalina, I got the error


#8

I’m always happy to open it up and see if I see anything out of the norm here. Please provide me a Build ID that I can pull down and test?


#9

I was talking about actuall build from XCode - I wanted to send. It comes from drop source I just added Firebase notifications to it


#10

This particular build is no longer in DS - but you will see in project file it came from DS


#11

Can you explain exactly what you’re doing to get the error and can you please screenshot anything helpful to see?


#12

Yes… I am just archiving the app and sending to apple so I can publish an update - to be processed and I get the error message I showed you before. It looks like apple has depreciated builds using this SDK framework to build in the latest Mac OS Catalina… Can you just send me an email I can send project file zip to please so you can take a look…


#13

#14

The error you’re showing me is for macOS Mojave Patcher. I want to be sure… is this image in this link the exact error you’re also seeing?