Constant Build Errors


#1

I have been having nothing but build errors with no errors being presented and no apparent cause I can find.

I have essentially deleted everything “new” since my last build and this hasnt made any difference at all.

I am unable to build my project at all.

the last build attempt is 1130671563362272809 and I am completely stuck

I would appreciate some assistance as I am at a complete standstill and have already lost a couple days work trying to systematically remove any potential culprits.

Thanks
Steve


#2

Hey Steve. Happy to help. The forum is here for this reason. I’ll have a look at this build Id and see what I can find out for you. We’ll help you get to where you want to go.


#3

Thank you Wade, I appreciate your help. I am completely handcuffed at this point.


#4

@steve1… would you sign out, sign back in and rebuild your project and let me know if it builds successfully? If not, please send a new build id. When i pulled that app down, it built just fine. I want to make sure this wasn’t an anomaly


#5

Also, try building for the web simulator instead of a device. I wonder if it’s a difference there maybe


#6

Hi Wade,

I will have to assume its an anomaly, after two days of repeated attempts and a Build fail every single time I signed in, hit build and it built successfully, without any change to the app from the previous failed build.

Any ideas what would cause this ?

Steve


#7

Perhaps I spoke to soon, I added a get API action to a page and now my app wont build anymore, even after deleting the API action from the page.

Please see the following build ID 1131747233542070456

Steve


#8

I was also unable to Duplicate my project, as both a backup and for testing possible causes of the error. Trying to duplicate the project threw an error.


#9

Build ID 1131755966284888443


#10

This is very interesting. I do see that on your side, these builds are failing. On my side when I pull the project down, it builds fine. I’m going to get engineering in on this as I think it could be something related to an internal framework here. Thanks for bringing this up and I am going to get back to you with more info as I receive it from them


#11

Thanks for looking into this Wade.
As this has brought me to a complete stop on this project do you have any suggestions for how I can move forward or an estimate as to when you anticipate a resolution ?
Is there any mechanism by which you can duplicate the project ?

Steve


#12

So, I have no idea what the problem is, but I created a brand new project, with nothing but a single blank page, hit build and it failed … So I am at a loss for what to do, beyond creating the account and purchasing the Source Code Download, I have no idea why I cant do anything, even build a brand new project or duplicated a project.


#13

If you’ve created a new project, did nothing but built it and it failed then there’s definitely something larger happening here. Can you share the build id of that new project that’s failing please?

Couple questions in addition to the Build ID…

Are you using Chrome Browser?
What version is your browser?


#14

Hi Wade,

I am using version 74.0.3729.169 (Official Build) (64-bit) of Chrome on Windows 10 without any extensions enabled. I’ve tried to build using Firefox and Firefox Developer Edition on my Windows 10 box.

I do have a new even stranger note to add, on a whim I pulled out my MacbookPro and fired up Chrome and tried to build, and it completed without a problem. I tried to duplicate a project, no problem, tried to build a new project, no problem. To confirm that I wasnt losing my mind I tried the build from my windows machine and once again, it failed, hopping back onto my Macbook thinking I could just continue to work from there, you guessed it, the build fails now and I’m once again screwed.

When attempting to run a build from a macOS, Linux or Windows Virtual Machine on my Windows machine I still get a build error. I’ve tried to disable all AV / Malware software and it made no difference, I’ve disabled my firewall temporarily and one again, no difference.

The new empty project build fail ID is 1132447276700375047.

The successful build from my macOS System is 1132674223989182929
The Failed windows build of the same project is 1132840160549730268
The subsequent fail on the macOS System is 1132842355105615211

I’m at a complete loss and I’m unsure what could be happening from my Windows machine that is “corrupting” my projects and account. At this point I’m unsure what exactly I should do and if I need to move to another platform to try and finish this App.

Thanks for your help.
Steve


#15

This is fantastic information. I’m passing all of this to Engineering to help them investigate. Maybe this is actually a Browser Operating System specific issue somehow.

Thanks for being so detailed in your research for us!


#16

We are seeing that sub resource files aren’t being created for the project. Engineering is investigating this issue internally and it appears another user is noticing a similar situation. I will pass more guidance as soon as I receive it from engineering.


#17

@fertrig Do we have any more information to aid @steve1 on this issue pertaining to sub resources files not being created. He has offered up great information in a couple replies above here that I shared with you before in case you need context for this.

Looking for some feedback / guidance to share to move forward.


#19

@steve1 A quick update here. We’re working this issue internally to provide the fix. We’ll update further as soon as we have more information.


#20

I am also having this same issue… build ID 1134650907017487541


#21

Having a lot of build issues, even with the sample Checklist app with no changes. Below are build IDs for 3 different apps that were building before, but are failing builds now.
Build ID: 1135386519398899486
Build ID: 1135385167061782031
Build ID: 1135384330143230937