Buttons not working inside a "view"? (iOS)


#1

Hi,

I am trying to get buttons inside a view to work. I have added an event on tapped to go to another page for example, but none of the buttons work. I have made sure user interactions are enabled on the view and on the buttons, still no result.

I am having the same problem with elements (however only in some cases) inside views.

What might be the cause of this?


#2

I’m happy to take a closer look.

Can you share a successful build id?

and walk me through the app from open to where the error is occurring please?


#3

I think I’ve had this same issue on IOS.

The solution for me was to use a label (filled from edge to edge without text) and set the Action to run on-click of the label (vs. the button or view).


#4

Sure Wade, check out: 1183197806039996311


#5

Thanks and please walk me through from app launch to the offending issue please. Thanks


#6

Sent you a private message :slight_smile:


#7

@AsgerVH,

It appears you solved it. In the Build ID you showed me, the User Interaction checkbox on that page was unchecked. It’s defaulted to being checked.

In your latest Build ID you’ve created, I checked that and the User Interaction checkbox on that page is now checked so I’m assuming you tinkered around and saw the error.

Your latest Build ID is functioning fine now in regards to that button functioning.