App Crashing but no build errors


#23

It’s building again today. Something is happening with your build server, then it clears up later. Could be it be overload on your build servers from other customers possibly?


#24

Worked all day then started happening again: Build ID: 1142961605508429505


#25

More failed builds with no errors: Build ID: 1143337376681164490


#26

Building again this morning. Any progression on what’s causing this?


#27

Seriously, do builds not work after a certain time? Build ID: 1143679054091577628


#28

@nate_frechette… Chris is having random issues where sometimes the app builds fine and other times it has a build error. I wonder if this is due to the duplicate provisioning profiles issue that he was experiencing before. I see that strange error about removing a UIGestureRecognizer from Mapkit and last time that was covering up the real issue which was a duplicate prov. profile.

Could you check on that suspicion with

Build ID 1143679054091577628
Project ID 954875935331636946


#29

Still having build issues: Build ID: 1144430384307056274


#30

Hey guys, this issue has been going on for a really long time, with no follow ups. Can someone update as to what’s going on?


#31

@chris we cleared out any old provisioning profiles which was an issue with your project before and we have engineering looking into the internal compiler for any larger issues. That’s the update I have so far. More to follow when I know more.


#32

@chris I’ve been told that there was an issue that was solved in our internal compilers that should help in your situation. See what happens now and let me know if it’s still occurring.


#33

Thank goodness!!! I will keep you posted.


#34

Still failing… Build ID: 1145134494236166400


#35

@wade @nate_frechette This thing has got to be some type of time sensitive issue. I can almost always build earlier in the day, as I can this morning, but never in the evening. I have no idea what your architecture looks like, but on the consumer end, this is what I seem to be experiencing.


#36

@chris, That last build Id seems to be problem free on my end when I download the source code and run locally.

@nate_frechette can you see anything internally to suggest why Chris would receive a Build Error with the id 1145134494236166400


#37

You not seeing any errors makes sense, because I don’t see any errors on my end in the editor.


#38

Build fail: 1146983289917670527
Build fail: 1146981913325832592

No errors.


#39

Passing these to Engineering Chris. I see these should be successful. @Nate is actively investigating what’s going on here so this is more data for him. Thanks for sharing this. We’ll update as soon as I have more info.


#40

Ok, FYI, built again this morning. Still seems time sensitive. (builds early, fails in the evening).


#41

Thanks for the heads up. I’ve passed this to engineering and will let you know as soon as I hear more back.


#42

Ok, another failed build Sunday night: 1148067653474222703