App Crashing but no build errors


My app is failing to build but I’m not getting any build errors.


Hi @chris,

This is due to an issue we’re currently working on solving internally. The engineers are aware of this MapKit issue and we’re working to solve it. I will let them know you’re also having this issue and will bookmark this thread and update you as soon as we have a solution and guidance to move past it. For now, removing the use of the Map page will get you beyond it but I hope we have this worked out next week.

Thanks for bringing this to our attention, Chris.


The map is a huge part of the app. Think Uber without the map page. So potentially, I won’t be able to get a new build until sometime next week???


Thanks for explaining the importance level of this functioning properly for you. You can still move forward in testing your app with the web simulator builds. This issue is only affecting Device Builds.

Engineering is aware and working the the issue. I will pass more information as I receive it. Thank you for your patience while we investigate and solve.


Actually, I cannot build in the simulator as well.


If you do a build for web simulator instead of a build for device build (selected in the build buttons drop down menu), it won’t successfully build for you?


Yes, the simulator build is working for me now. At first it was not.


Will this issue affect any existing builds that uses the map object?



I heard back from engineering. The real issue was being hidden by a different error. This was actually an issue with a duplicate provisioning profile for your project in your account. We’ve solved it.

Would you rebuild and test your project out please?


Looks like it’s been fixed since yesterday morning. Thanks!


Excellent to hear @chris!


I’m having this issue again. Build fails and no errors.


I can take a look. Are you getting a Build ID from I can take a look at?


It’s building now. Not sure if you guys cleared the cache again your end like before since I sent that message.


Getting the issue again, man this is frustrating. I can’t get build number because the project is failing.


It stopped doing it again. What is causing my project to go these long extended periods of not being able to build. Walk away for several hours then it builds again? Major productivity killer. Do the engineers know what might be going on?


This seems like something new relatively new. Just wondering but when you click build, you’re not trying to build several times before a build in progress is competing at all by chance? I imagine not but it could be something to clog up the internal builder potentially.


No couldn’t build last night, tried one time this morning and it told me I had too many failed builds but I’ve only tried once this morning. Currently still cannot build.


Is it giving you any build id’s that I can look deeper into?


I have a build ID for you: Build ID: 1142600174563292758