[Resolved] Projects Failing to Build


Is anyone else having issues with their projects showing zero errors but failing to build? I have tried my main app project and then duplicated an example project(To Do Checklist) and tried to build both. Both failed unfortunately and there’s no error. My unsuccessful build ID is 1125954736654424971.


Hi Matt!

Thanks for reaching out. So I pulled this down and there’s an error in the code related to GestureRecognizers and deselecting annotation on the map. I made a test app and set my map up just like yours and my works so as weird as this sounds… Would you run this test… Delete your MapView in the LocationInfo page, build the app and see if it Builds Successfully. If it doesn’t after you delete the map, please pass me the new Build ID. If it works, try just dropping a mapview back into the page and building again and see if this is just some wonky thing happening. I don’t see anything obvious in your app that should draw out the error I see you’re having so this is more of a “let’s backpaddle” and see if it’s a fluke


Hey @wade, oddly enough, I didn’t change anything and this morning it built just fine. Thanks for looking into it. If I have any other issues, I will let you know.


Strange. It did give me the feeling of a fluke bug. I’m glad it fixed itself. Thanks for bringing it up and sorry that it threw you a curveball there.


No worries. Glad it sorted itself. It honestly might have been a load of cache in my machine throwing it off. I actually turned my computer off last night for the first time in a while so that is probably what fixed it.



1 of my favorite series out there!

Glad it got solved with a simple restart! Keep up the amazing work!


Thanks dude! Also, this is the way to handle an issue of this nature, correct? I know the developer assistance is now an add so I just want to make sure that this is how issues like this should be submitted if we aren’t using that channel.


This is a fine method to handle it and thanks for asking. This allows others to gain value and/or offer insight in the troubleshooting processes too. We all work together to get every developer to the finish line.


Great to hear. Just wanted to make sure that I wasn’t flooding the forum with unnecessary content. Thanks for all of the help Wade.


That’s what it’s here for sir. And you’re welcome to hop in with anyone else. Everyone can be tagged. It’s a pretty calm forum but when you tag someone in a post, they usually speak up.


hey @wade

Still seeing this issue again. Just happened on a couple build attempts. Here is the most recent build ID: 1127775952799345265

Not sure exactly what’s happening here. I set the map view toggles to off to see if that was the issue but nothing changed.


Hi Matt,

Thanks very much for the update on this. I pulled down your app and ran it and am coming across this error in code related to a gesture recognizer object not set as a parameter in this function call. I am not exactly certain why this is occurring and I’m also wondering if this is perhaps an issue internally that we need to solve on our side.

I reached out to engineering to gain more info here and provide guidance. I will report back as soon as I know more.


Hey @wade,
So I attempted a few builds after that failed build and low and behold I got one to go through. It looks like this error is from a page called PageLocMap. That was a page I had inside of a page controller and I removed the entire page and the build finally worked. So maybe a map view inside of a page controller?


Interesting solve. I’m going to test this on my end and nest a MapView inside a page controller. That could be why mine worked fine and yours was breaking. Nice work self troubleshooting and seeing what would make the difference. We’re still going to look into the issue so the confusion is solved for the next time.

Thanks for working with us on this and great work overcoming the issue. Also, thanks for sharing what worked for you here and we can look into why it broke in the first place.


@matt I just responded to another thread that I think was related to this same issue with you. Are you currently moving forward again?


@wade. I believe that I am moving forward. If anything comes up again I will let you know. I have changed my approach a little and the new way seems to be working just fine. Thanks!


Excellent to hear, Matt! Thanks so much for the follow up!


@wade. Actually I just attempted a build and it didn’t compile. Did you guys change when a build fails? Now it prompts to send a request to support.


I’ll take a look. Send me a build id for the 1 failing if you don’t mind.


Here you go! 1130509912207798269

Thanks Wade