Critical Save Error


#21

Engineering is aware of this and is investigating. I’ll pass details and guidance as soon as I receive them.


#22

Thank you…


#23

Alright. Time to test… logout if dropsource and do a hard refresh of your browser from the dev console.

There’s some shortcuts to do the hard refresh here based on platform.

Then quit chrome, reopen, log back into dropsource, and rebuild your project.

Lots of steps but I want to ensure a full refresh of the chrome browser and dropsource on your sides here.


#24

Looks like it’s still not saving.


#25

Now it appears to be saving after it didn’t initially work.


#26

Great to hear! Thanks for giving it a test.


#27

What is the solution here?

I keep getting this error routinely and randomly and don’t know what to do about it…

It makes for a frustrating user experience where we can’t develop anymore.

I have tried the suggestions but it didn’t work and I don’t know what causes this.

Logged out of DS, shift+f5, closed and re-opened browser etc.

Is it within the browser itself? Or the back end?

All that was done was a re-import of the swaggar file (that timed out and produced an error which we were advised to just refresh the browser and hope all the calls showed up) - they showed up, but we keep getting the Critical Save Error


#28

I believe it’s a caching issue on their end. I don’t think it’s anything, we as end users can do about it. But man!, do I ever feel your pain. I would like @wade to chime in to confirm though.


#29

I’ve been following the discussion. Nate is aware and researching the issue still. Engineering thought they had it solved but it appears not yet. Thank you both for continuing to update as well as testing when we attempt solutions.


#30

No, it’s working for me. I think @justincrabbe was just trying to find out why it’s been happening, and was there anything we could do on our end to prevent it. Which I didn’t think so.


#31

Ah I see. Thank you. If there is, I’ll share it out. This may be internal but engineering is still looking into it more.