Created App - Downloaded to Android Store - Nothing there


#21

I did everything above and the APK ended up working. Create a brand new app (to simply potential issues) uploaded APK, everything good there. App was on the store, but still didnt have anything to open. I double checked i have the icon image in dropsource. So i figured why not just do another build and redo the source code to make sure. I then followed back through all the steps and i got to the same error i had before. closed out and updated android studio still there.

Not sure what the issue is.

In the description above from Wade:

You will go over to Android Studio and “open an existing project” - your referring to the original project, correct?

and highlight that highest folder… then click open. - Does this folder need to be in the same location as where the original project is? Does it need to go within the project?


#22

So the project I’m referring to is the brand new build. Every single time you download source code, it’s like a brand new app. When you go updating the old version on the Play Store to your newest source code version of the app, you’ll have to open up the new app project you just downloaded on your machine, in Android Studio. It won’t sit within the old project or anything like that. It’s like it’s a brand new app. It’s basically like a duplicated version of the old app, but now has your newest changes in it.

You download the new app build from Dropsource onto your machine. When you go open an “existing project” in Android studio, it’s just referring to an app that’s already in the process and created as opposed to Android Studio creating a brand new app from scratch.

So you’ll Build your project in Dropsource, download the source code, know where it’s saved (heck you can delete the old version on your computer since it’s pretty much moot now), and open that new project in Android Studio from the top most folder of it. Then make that version numbering adjustment like we talked about… then follow the deployment process in the help resources from start to finish with the caveat being that you’re updating the app in Android Play Store. Android Play Store will notice that they are the same projects and will also see the incremented build id (because you changed it manually before archiving your project in Android Studio) and it will overwrite what’s in the Play Store now with your new app project. Then you’ll go to the Play Store and download the update. This will then overwrite the app that used to be on your phone with the new 1 you just downloaded from the Play Store. At that point, you have the new app on your device.
@cchute correct me if I have that wrong at all please but that’s my understanding. Also Carl, there’s no need to make any adjustment to the bundle id or anything for the new app project Trevor gets when he downloads his latest build’s source code from Dropsource, right?


#23

Wade,

We still have not figured out why my app has nothing on it. Its on the store where it can install but doesnt have the ability “to open”.

When i come in with a new build i’m still getting that same error. Unsupported Method. Can we have a screenshare session, i think it will save on the back and forth.


#25

Quick follow up @trevor.hileman, Carl is 1 of our Android Engineers and he’s going to give you a hand getting over this hurdle. He’s got a couple things in the queue and as soon as he’s free, he’ll be stepping in to help you more on this so you can move forward.

Thanks for your patience.


#26

Hi can you provide the google play store link?

I’d suggest deleting any old versions of the app, restarting the device and trying again.

thanks,

Carl


#27

I have done this and nothing. Are you saying that in the source code everything is there, and that everything should be working properly?


#28

I believe the 1st part he is asking is for the link so he can download your app from the Play Store so we can test it out and see the issue firsthand.


#29

https://play.google.com/store/apps/details?id=com.Resco.RescoApp2


#30

Thanks I’m seeing the error, can you email me the apk file that you uploaded to Google Play? Something might be wrong with the app signing cchute@dropsource.com?


#31

Thank you for your support @cchute @wade @markpiller @seanhoots for the non tech person like me


#32

Wanted to check in, i did email you the APK file but have not heard anything.

Thank you.


#33

Hi I haven’t received the email, can you try again? note there’s two C’s at the beginning of the address. Thanks

cchute@dropsource.com


#34

I did have it correct. I resent.

Make sure it didn’t go to spam. Originally sent Wed @ 1:14pm.

Thank you


#35

hmmm that’s odd it’s not coming through, can you try emailing it to @wade? wsellers@dropsource.com


#36

Sure. Yea try sending it my way. wsellers@dropsource.com


#37

Sent again, including Wade


#38

Nothing received on my side. I don’t know why it’s not being received. @cchute do you want to go the old style route here and generate an APK and help him deploy it like we used to offer? Seems like this might make for an exception to the rule with the difficulties and delays on this specific instance.


#39

Yeah let’s do that it’ll be easier, can you regenerate the DropSource project with a new Identifier and send me the build ID and Google Play credentials? We’ll delete the old app and get a fresh one in hopefully that resolves the issue.


#40

To round this thread out for anyone reading along and looking to gain value from the trials and errors here, we’re taking this convo into a private message so that we preserve the integrity of the account’s security here.