Connecting a Dropsource app to Backendless


Hope you don’t mind but I tried it in Dropsource, the issue seems to be that the equals sign is not urlencoded by default, but by including the urlencoded version Dropsource then encodes the percent sign part of it which means it’s not what Backendless wants… :roll_eyes:

I’ve tried various options to encode/escape characters but no luck, I’m going to ping the engineering team in case anyone can think of a workaround…


Thank you Sue. Appreciate your efforts.


Hence, the text input box instead of sending the actual desired variable… I have tried it all sorts of ways.


Hi @edar, so it turns out one of our engineers had encountered this issue with “where” queries / Backendless and had reported it internally, and we do not have a current workaround for it. The engineering team is currently analyzing whether and how they would implement a change to support this - changing how we do urlencoding would be a pretty major undertaking that would potentially affect other projects, so at this stage it’s unclear whether we will decide to go ahead with that, especially since we haven’t encountered the issue with any other backend provider so far…

At this stage I’m thinking you might be best to explore other backend options because even if we do change our encoding to support this structure it’s likely to be some time before you would see that change in the platform. Sorry I don’t have better news!


Hi edar, just came across your post and was wondering if you found a solution as I got the same problem.
Thank you


Hi @signoretti.riccardo, We also have @markpiller who is with Backendless in the forum here too. I’m not sure if Backendless has made any updates since this post is from 1 year ago but maybe there’s newer information regarding your particular situation.

Perhaps you’d like to explain more of what you are building and what you need specifically from Backendless. I’m hopeful there’s updated information here.